Netflix stopped working;on my H2 ?!

  • Hi, I'm having the same issue. I just bought a new H2 and after installing Netflix via Aptoide it won't let me log in but keeps saying "Sorry we could not reach the Netflix service. Please try again later."

    Factory reset did not help. Latest firmware is installed.

    Can you help me out? Thinking about returning it.

  • @Abri234 Hi dear, sorry for the inconvenience caused.

    I have forwarded this issue to our tech team, please be patient.

  • Hello,

    My Netflix app stop working too few days ago… I bought the H2 less than a month ago i'm on the v1.3.4, I downloaded the netflix app via aptoidetv, I can login but when a video start I have this message : "Sorry we could not reach the Netflix service. Please try again later. (0013)".
    I tried to re install the app but it still not working.

    I had some issues with my youtube app (videos freezing after 1 sec playing) but I just managed to fixed it by uninstalling all the updates via GooglePlay app, but it's not possible for Netflix.

    Last question, since yesterday my H2 is quite noisy and I have no idea why, the ventilator wasn't doing much sound before but now I can hear it much louder.

  • @KVN Hi, thanks for your support.

    Could you please email me attaching the video of noise issue? I'll check it for you.
    I shall check the netflix issue together, please don't worry.

  • @Ari Hi,
    I just sent the mail to you !

    Thank you

  • Try to download the latest version from Netflix site... ☺

  • Hi,

    Anyone with Netflix or Amazon Prime issue can try to check this solution working as of now I published on this topic

    Hopefully it helps.

  • Is anyone successful playing Netflix? None of the APKs referenced in other threads seem to work 😞 Now I'm thinking to return my H2 to Amazon, having to use a fire stick defeats the purpose to have a smart projector in the first place.

  • @stack same just now on mine h2 as well how to fix this problem thanks ...

  • @Ari Hi,
    I have the Same issue with my netflix app on the H2.
    it's asking e to update my google play services but when I follow the link it's not working…

  • Please support! My H2 also cannot use youtube and netflix

Log in to reply





Active Users